DeprecationWarning: Tapable.plugin is deprecated. Use new API on `.hooks` instead (node:7788) DeprecationWarning: Tapable.apply is deprecated. Call apply on the plugin directly instead

背景: 在通过 npm run dev 命令运行一个Vue项目时,出现了如下报错信息 DeprecationW …

access to XMLHttpRequest at ‘http:www’ from origin ‘http://’ has been blocked by CORS policy: The value of the ‘Access-Control-Allow-Origin’ header in the response must not be the wildcard ‘*’ when the request credentials mode is ‘include’ . The credentials mode of requests initiated by the XMLHttpRequest is controlled by the withCredentials attribute

背景: 将Vue 项目部署到服务器以后,运行时出现如下报错信息 access to XMLHttpReques …

Failed to compile. ./src/main.js Module build failed (from ./node_modules/@vue/cli-plugin-babel/node_modules/babel-loader/lib/index.js): Error: Cannot find module ‘babel-plugin-import’ from ‘C:\Users\Administrator\WebstormProjects\memorial’ at Function.resolveSync [as sync] (C:\Users\Administrator\WebstormProjects\memorial\node_modules\resolve\lib\sync.js:89:15) at resolveStandardizedName

背景: Failed to compile. ./src/main.js Module build faile …

Vue packages version mismatch: – vue@2.6.12 (C:\Users\Administrator\WebstormProjects\memorial\node_modules\vue\dist\vue.runtime.common.js) – vue-template-compiler@2.6.11 (C:\Users\Administrator\WebstormProjects\memorial\node_modules\vue-template-compiler\package.json)

背景: INFO Starting development server… 10% building 2/2 …